Biztonsági figyelmeztetések

Wysiwyg - Moderately critical - Cross site scripting - SA-CONTRIB-2022-003

Biztonsági figyelmeztetések (contrib) - 2022. január 5. 18.50
Project: WysiwygDate: 2022-January-05Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross site scriptingDescription: 

This module enables you to integrate various What-You-See-Is-What-You-Get (WYSIWYG) rich text editors into Drupal fields with text formats allowing markup for easier editing.

The module doesn't sufficiently sanitize user input before attaching a WYSIWYG editor to an input field such as a textarea. If the editor used has an XSS vulnerability this would allow for example a commenter to put specially crafted markup which could trigger the vulnerability when viewed in the editor by an administrator.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission to create content using a text format with an attached and XSS vulnerable rich text editor.

Solution: 

Install the latest version:

After upgrading verify that text formats which have a WYSIWYG editor profile also uses a text filter, such as Core's "Limit allowed HTML tags", if accessible by untrusted users.
A list of known compatible input filters that will be applied is shown when configuring a WYSIWYG editor profile along with a status indicator.

It is recommended to always be using the latest stable version of any installed editor libraries.

Reported By: Fixed By: Coordinated By: 

Simple OAuth (OAuth2) & OpenID Connect - Moderately critical - Access bypass - SA-CONTRIB-2022-002

Biztonsági figyelmeztetések (contrib) - 2022. január 5. 18.12
Project: Simple OAuth (OAuth2) & OpenID ConnectDate: 2022-January-05Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Access bypassDescription: 

This module enables you to implement OAuth 2.0 authentication for Drupal.

The module doesn't sufficiently verify client secret keys for "confidential" OAuth 2.0 clients when using certain grant types. The token refresh and client credentials grants are not affected.

This vulnerability is mitigated by the fact that the vast majority of OAuth 2.0 clients in the wild are public, not confidential. Furthermore, all affected grant types still require users to authenticate to Drupal during the OAuth flow.

The implicit grant type is insecure for other reasons (and still requires user authentication) and is disabled by default.

Sites at risk of information disclosure would be specifically configured to restrict access based on the OAuth client's confidentiality status and configured scopes, not only traditional Drupal user permissions and roles.

Further mitigation includes configuring allowed redirect URIs for clients. This is an OAuth best practice for guarding against man-in-the-middle attacks on authorization codes, and prevents redirection to imposter clients.

Anyone implementing OAuth 2.0 on their Drupal site is also encouraged to review the relevant RFCs and Internet-Drafts pertaining to OAuth security.

Solution: 

Install the latest version:

Important note: 8.x-4.6 will be the last release for the 8.x-4.x branch. Support for this major version will end February 28, 2022. The upgrade path to 5.x is easy, supported and well-tested. All users of versions < 5 should upgrade to 5.2.0.

The 5.0.x version will be supported until July 31, 2022. Read the 5.2.0 change record for information about changes to previously non-spec-compliant response codes and messages.

Reported By: Fixed By: Coordinated By: 

Super Login - Critical - Access bypass - SA-CONTRIB-2022-001

Biztonsági figyelmeztetések (contrib) - 2022. január 5. 18.06
Project: Super LoginDate: 2022-January-05Security risk: Critical 18∕25 AC:None/A:None/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

This module enables you to login with an email address.

The module doesn't sufficiently check if a user account is active when using email login.

This vulnerability is mitigated by the fact that an attacker must have an account in the website that is blocked.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Mail Login - Moderately critical - Access bypass - SA-CONTRIB-2021-047

Biztonsági figyelmeztetések (contrib) - 2021. december 22. 18.47
Project: Mail LoginDate: 2021-December-22Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

This modules enables users to login via email address.

This module does not sufficiently check user status when authenticating.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Search API Pages - Critical - Cross Site Scripting - SA-CONTRIB-2021-046

Biztonsági figyelmeztetések (contrib) - 2021. december 8. 19.11
Project: Search API PagesDate: 2021-December-08Security risk: Critical 16∕25 AC:None/A:None/CI:Some/II:Some/E:Theoretical/TD:UncommonVulnerability: Cross Site ScriptingDescription: 

This module enables you to create simple search pages based on Search API without the use of Views.

The module doesn’t sufficiently escape all variables provided for custom templates.

This vulnerability is mitigated by the fact that the default template provided by the module is not affected.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Webform - Critical - Cross Site Scripting, Access Bypass - SA-CONTRIB-2021-045

Biztonsági figyelmeztetések (contrib) - 2021. december 8. 19.02
Project: WebformDate: 2021-December-08Security risk: Critical 16∕25 AC:Basic/A:None/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross Site Scripting, Access BypassDescription: Access Bypass:

This module enables you to build forms and surveys in Drupal.

The module doesn't sufficiently check access for administrative features for webforms attached to nodes using the Webform Node module. This may reveal submitted data or allow an attacker to modify submitted data. Additionally, for sites with webforms that send emails and store submissions this vulnerability would allow an attacker to use the site as an email relay (i.e. sending arbitrary emails).

There is no mitigation for this vulnerability. If you have the Webform Node module enabled you must update the Webform module.

Cross Site Scripting:

The Webform module enables site builders to create forms and surveys.

The Webform module doesn't sufficiently filter HTML when an element's 'Help title' and an 'Image Select' element's image text contain specially crafted malicious text.

This vulnerability is mitigated by the fact that an attacker must be able to create or edit webforms.

Solution: 

Install the latest version:

  • If you use the Webform module for Drupal 9.x, upgrade to Webform 6.1.2 or Webform 6.0.6
  • If you use the Webform module version 8.x-5.x it is affected by this issue and is unsupported. You should upgrade to Webform 6.
Reported By: Access Bypass: Cross Site Scripting: Fixed By: Access Bypass: Cross Site Scripting: Coordinated By: 

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2021-011

Biztonsági figyelmeztetések (core) - 2021. november 17. 22.28
Project: Drupal coreDate: 2021-November-17Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross Site ScriptingDescription: 

The Drupal project uses the CKEditor library for WYSIWYG editing. CKEditor has released a security update that impacts Drupal.

Vulnerabilities are possible if Drupal is configured to allow use of the CKEditor library for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.

For more information, see CKEditor's security advisories:

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

Versions of Drupal prior to 9.1.x are end-of-life and do not receive security coverage.

Note that Drupal 8 has reached its end of life so this is the final security release provided for Drupal 8.

Drupal 7 core does not include the CKEditor module and therefore is not affected.

Reported By: 
  • Jacek Bogdański coordinated on the release with Drupal project.
  • See the CKEditor announcements above for the original reporters of the vulnerabilities.
Fixed By: 

OpenID Connect Microsoft Azure Active Directory client - Moderately critical - Access Bypass - SA-CONTRIB-2021-044

Biztonsági figyelmeztetések (contrib) - 2021. november 17. 16.45
Project: OpenID Connect Microsoft Azure Active Directory clientDate: 2021-November-17Security risk: Moderately critical 14∕25 AC:Complex/A:None/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Access BypassDescription: 

This module enables users to authenticate through their Microsoft Azure AD account.

The module does not sufficiently check authorization before updating user profile information in certain non-default configurations. This could lead a user being able to hijack another existing account.

This vulnerability is mitigated by the fact that an attacker must have knowledge of user accounts that have the administrator role or accounts with the 'Set a password for local authentication' permission. In addition the site must be configured with the 'Update email address in user profile' setting turned on.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Loft Data Grids - Moderately critical - XML External Entity (XXE) Processing - SA-CONTRIB-2021-043

Biztonsági figyelmeztetések (contrib) - 2021. október 13. 18.32
Project: Loft Data GridsDate: 2021-October-13Security risk: Moderately critical 11∕25 AC:Complex/A:Admin/CI:Some/II:Some/E:Proof/TD:UncommonVulnerability:  XML External Entity (XXE) ProcessingDescription: 

This module enables aklump/loft_data_grids to be used as a Drupal module.

Excel support was provided by https://packagist.org/packages/phpoffice/phpexcel, which is abandoned and there are known security vulnerabilities: [CVE-2018-19277]: PHPOffice/PhpSpreadsheet#771. Excel support has since been replaced with the newer https://github.com/PHPOffice/PhpSpreadsheet library.

This module provides an API and This vulnerability is not exploitable in the module itself. This vulnerability only exists if custom code or another module uses the API of this module to read a spreadsheet.

Solution: 

Upgraded to the the latest version.

Reported By: Fixed By: Coordinated By: 

Linkit - Moderately critical - Cross Site Scripting - SA-CONTRIB-2021-042

Biztonsági figyelmeztetések (contrib) - 2021. szeptember 29. 16.38
Project: LinkitDate: 2021-September-29Security risk: Moderately critical 12∕25 AC:Basic/A:Admin/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross Site ScriptingDescription: 

Linkit provides an easy interface for internal and external linking with WYSIWYG editors by using an autocomplete field.

It does not sufficiently sanitize user input.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission to create or edit an entity bundle.

Solution: 

Install the latest version:

  • If you use the Linkit module for Drupal 8.x, upgrade to Linkit 8.x-4.4
Reported By: Fixed By: Coordinated By: