Hírolvasó

Wingsuit - Storybook for UI Patterns - Critical - Access bypass - SA-CONTRIB-2022-040

Biztonsági figyelmeztetések (contrib) - 2022. május 18. 19.13
Project: Wingsuit - Storybook for UI PatternsVersion: 8.x-2.x-dev8.x-1.x-devDate: 2022-May-18Security risk: Critical 16∕25 AC:Basic/A:None/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

The Wingsuit module enables site builders to build UI Patterns (and|or) Twig Components with Storybook and use them without any mapping code in Drupal.

The module doesn't have an access check for the admin form allowing an attacker to view and modify the Wingsuit configuration.

Solution: 

Install the latest version:

  • If you use the wingsuit_companion 8.x-1.x module for Drupal 8.x, upgrade to Wingsuit 8.x-1.1
Reported By: Fixed By: Coordinated By: 

Duo Two-Factor Authentication - Critical - Unsupported - SA-CONTRIB-2022-039

Biztonsági figyelmeztetések (contrib) - 2022. május 4. 18.37
Project: Duo Two-Factor AuthenticationDate: 2022-May-04Security risk: Critical 15∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:AllVulnerability: UnsupportedDescription: 

The security team is marking this project unsupported. If you would like to maintain this project, please read: https://www.drupal.org/node/251466#procedure---own-project---unsupported.

Quick Node Clone - Moderately critical - Access bypass - SA-CONTRIB-2022-038

Biztonsági figyelmeztetések (contrib) - 2022. május 4. 18.26
Project: Quick Node CloneDate: 2022-May-04Security risk: Moderately critical 10∕25 AC:Complex/A:Admin/CI:None/II:Some/E:Proof/TD:AllVulnerability: Access bypassDescription: 

The module adds a "Clone" tab to a node. When clicked, a new node is created and fields from the previous node are populated into the new fields. This module supports paragraphs, groups, and other referenced entities.

The module has a vulnerability which allows attackers to bypass the protection to clone any group content with an access check. Users are allowed to copy other group's nodes, and if they do that, the node gets added to groups they don't have access to.

This vulnerability is mitigated by the fact it only affects sites that also use the Groups contributed module.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Image Field Caption - Moderately critical - Cross Site Scripting - SA-CONTRIB-2022-036

Biztonsági figyelmeztetések (contrib) - 2022. május 4. 18.11
Project: Image Field CaptionVersion: 8.x-1.1Date: 2022-May-04Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross Site ScriptingDescription: 

Image Field Caption (image_field_caption) adds an extra text area for captions on image fields.

The module doesn't sanitize user input in certain cases, which leads to a Cross-Site-Scripting (XSS) vulnerability.

The vulnerability is mitigated by several permissions, of which at least some are commonly only assigned to either editors, site builders or administrators.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Doubleclick for Publishers (DFP) - Moderately critical - Cross site scripting - SA-CONTRIB-2022-035

Biztonsági figyelmeztetések (contrib) - 2022. május 4. 18.06
Project: Doubleclick for Publishers (DFP)Date: 2022-May-04Security risk: Moderately critical 13∕25 AC:Basic/A:Admin/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross site scriptingDescription: 

Doubleclick for Publishers (DFP) module enables a site to place ads from Doubleclick For Publishers.

The module doesn't sanitize user input in certain cases, which leads to Cross-Site-Scripting (XSS) vulnerabilities. An attacker that can create or edit certain entities may be able to exploit a Cross-Site-Scripting (XSS) vulnerability to target visitors of the site, including site admins with privileged access.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer DFP".

Solution: 

Install the latest version:

  • If you use the Doubleclick for Publishers module for Drupal 9.x, upgrade to DFP 8.x-1.2

Note that the Drupal 7 version of this module is unaffected.

Reported By: Fixed By: Coordinated By: 

Link - Moderately critical - Cross site scripting - SA-CONTRIB-2022-034

Biztonsági figyelmeztetések (contrib) - 2022. május 4. 18.01
Project: LinkDate: 2022-May-04Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross site scriptingDescription: 

This module enables you to add URL fields to entity types with a variety of options.

The module doesn't sufficiently filter output when token processing is disabled on an individual field.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission to create content and the token processing option must be disabled.

Solution: 

Install the latest version:

  • If you use the Link module for Drupal 7.x, upgrade to Link 7.x-1.11
Reported By: Fixed By: Coordinated By: 

Drupal core - Moderately critical - Access bypass - SA-CORE-2022-009

Biztonsági figyelmeztetések (core) - 2022. április 20. 17.07
Project: Drupal coreDate: 2022-April-20Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Access bypassDescription: 

Drupal 9.3 implemented a generic entity access API for entity revisions. However, this API was not completely integrated with existing permissions, resulting in some possible access bypass for users who have access to use revisions of content generally, but who do not have access to individual items of node and media content.

This vulnerability only affects sites using Drupal's revision system.

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

All releases prior to Drupal 9.3 (including Drupal 7) are not affected.

Reported By: Fixed By: 

Drupal core - Moderately critical - Improper input validation - SA-CORE-2022-008

Biztonsági figyelmeztetések (core) - 2022. április 20. 17.04
Project: Drupal coreDate: 2022-April-20Security risk: Moderately critical 12∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:UncommonVulnerability: Improper input validationDescription: 

Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

We do not know of affected forms within core itself, but contributed and custom project forms could be affected. Installing this update will fix those forms.

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

All versions of Drupal 9 prior to 9.2.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.

Drupal 7 is not affected.

Reported By: Fixed By: 

Rename Admin Paths - Moderately critical - Access bypass - SA-CONTRIB-2022-033

Biztonsági figyelmeztetések (contrib) - 2022. április 12. 19.17
Project: Rename Admin PathsVersion: 7.x-2.37.x-2.27.x-2.1Date: 2022-April-12Security risk: Moderately critical 10∕25 AC:Basic/A:None/CI:None/II:None/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

The Rename Admin Path module provides additional security to Drupal sites by renaming the admin paths. The module has a vulnerability with allows attackers to bypass the protection by using specially crafted URLs.

The risk is mitigated by the fact that, even though the attacker can bypass the protection offered by this module, all regular permissions still apply.

Solution: 

Install the latest version:

Only the 7.x version of the module is vulnerable. If you use the 8.x version, you do not have to take any action.

Reported By: Fixed By: Coordinated By: 

Anti Spam by CleanTalk - Moderately critical - SQL Injection - SA-CONTRIB-2022-032

Biztonsági figyelmeztetések (contrib) - 2022. március 30. 20.23
Project: Anti Spam by CleanTalkDate: 2022-March-30Security risk: Moderately critical 14∕25 AC:Basic/A:None/CI:None/II:All/E:Theoretical/TD:DefaultVulnerability: SQL InjectionDescription: 

This module provides integration with the CleanTalk spam protection service.

The module does not properly filter data in certain circumstances.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Role Delegation - Moderately critical - Privilege escalation - SA-CONTRIB-2022-031

Biztonsági figyelmeztetések (contrib) - 2022. március 23. 17.39
Project: Role DelegationDate: 2022-March-23Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:DefaultVulnerability: Privilege escalationDescription: 

This module allows site administrators to grant specific roles the authority to assign selected roles to users, without them needing the administer permissions permission.

The module contains an access bypass vulnerability when used in combination with the Views Bulk Operations module. An authenticated user is able to assign the administrator role to his own user.

This vulnerability is mitigated by the fact that an attacker must have access to an overview of users with the views bulk operations module enabled. E.g. The admin_views module provides such a view.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Colorbox Node - Critical - Unsupported - SA-CONTRIB-2022-030

Biztonsági figyelmeztetések (contrib) - 2022. március 23. 17.36
Project: Colorbox NodeDate: 2022-March-23Security risk: Critical 15∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:AllVulnerability: UnsupportedDescription: 

The security team is marking this project unsupported. There is a known security issue with the project that has not been fixed by the maintainer. If you would like to maintain this project, please read: https://www.drupal.org/node/251466#procedure---own-project---unsupported

This module was unsupported on 2022-01-26, however, the SA was missed in publishing them at that time.

Solution: 

If you use this project, you should uninstall it. To take over maintainership, please read https://www.drupal.org/node/251466#procedure---own-project---unsupported in full.

Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-006

Biztonsági figyelmeztetések (core) - 2022. március 21. 22.39
Project: Drupal coreDate: 2022-March-21Security risk: Moderately critical 11∕25 AC:Complex/A:None/CI:None/II:Some/E:Theoretical/TD:DefaultVulnerability: Third-party librariesCVE IDs: CVE-2022-24775Description: 

Drupal uses the third-party Guzzle library for handling HTTP requests and responses to external services. Guzzle has released a security update which may affect some Drupal sites.

We are issuing this security advisory outside our regular Drupal security release window schedule since Guzzle has already published information about the vulnerability, and vulnerabilities might exist with core, contributed modules, or custom modules that use Guzzle for outgoing requests. Guzzle has rated this vulnerability as low-risk.

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

All versions of Drupal 9 prior to 9.2.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.

Drupal 7 is not affected.

Reported By: Fixed By: 

Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-005

Biztonsági figyelmeztetések (core) - 2022. március 16. 17.10
Project: Drupal coreDate: 2022-March-16Security risk: Moderately critical 13∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Third-party librariesCVE IDs: CVE-2022-24728CVE-2022-24729Description: 

The Drupal project uses the CKEditor library for WYSIWYG editing. CKEditor has released a security update that impacts Drupal.

Vulnerabilities are possible if Drupal is configured to allow use of the CKEditor library for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.

For more information, see CKEditor's security advisories:

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

All versions of Drupal 9 prior to 9.2.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.

Instructions for Drupal 7 and contributed modules

Drupal 7 core is not affected, although Drupal 7, 8, and 9 site owners should review their site following the protocol for managing external libraries and plugins previously suggested by the Drupal Security Team, as contributed projects may use additional CKEditor plugins not packaged in Drupal core.

Users of the Webform module should ensure Webform's version of CKEditor 4 is also up-to-date after updating Drupal core and libraries for any affected contributed modules. If it is not, Webform users can try the following steps to update it:

  1. If using Composer, run drush webform:libraries:composer > DRUPAL_ROOT/composer.libraries.json and run composer update
  2. If using Drush without Composer, run drush webform:libraries:update.

Learn more about updating Webform libraries.

Reported By: Fixed By: 

Opigno Learning path - Moderately critical - Access bypass - SA-CONTRIB-2022-029

Biztonsági figyelmeztetések (contrib) - 2022. március 9. 19.57
Project: Opigno Learning pathDate: 2022-March-09Security risk: Moderately critical 13∕25 AC:Basic/A:None/CI:Some/II:None/E:Theoretical/TD:AllVulnerability: Access bypassDescription: 

This module is used as part of the Opigno LMS distribution and implements learning paths for the LMS.

The module was providing too much user information about users such as the list of groups a uid is in.

Solution: 

Install the latest version:

Reported By: Fixed By: 

SVG Formatter - Critical - Cross Site Scripting - SA-CONTRIB-2022-028

Biztonsági figyelmeztetések (contrib) - 2022. március 9. 19.28
Project: SVG FormatterDate: 2022-March-09Security risk: Critical 15∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:AllVulnerability: Cross Site ScriptingDescription: 

SVG Formatter module provides support for using SVG images on your website.

Our dependency library enshrined/svg-sanitize has a cross-site scripting vulnerability.

This vulnerability is mitigated by the fact that an attacker must have a role with permission that enables them to upload SVG images.

Solution: 

Update the module (8.x-1.17 or 2.0.1) which will enable updating to the enshrined/svg-sanitize to version 0.15 or newer library.

The updated library is most easily installed with Composer. To update the module and library it's possible to run the following Composer command:

composer update --with-dependencies drupal/svg_formatterReported By: Fixed By: Coordinated By: 

GOV.UK Theme - Moderately critical - Cross site scripting - SA-CONTRIB-2022-027

Biztonsági figyelmeztetések (contrib) - 2022. február 23. 18.18
Project: GOV.UK ThemeDate: 2022-February-23Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross site scriptingDescription: 

The GOV.UK Theme (govuk_theme) is a Drupal theme for the GOV.UK Design System.

The theme doesn't sanitize user input in certain cases, which leads to Cross-Site-Scripting (XSS) vulnerabilities. An attacker that can create or edit certain entities or configuration may be able to exploit one or more Cross-Site-Scripting (XSS) vulnerabilities to target visitors of the site, including site admins with privileged access.

The vulnerability is mitigated by the facts, that:

  • An attacker must have one of several permissions, of which at least some are commonly only assigned to either editors, site builders or administrators.
  • For some of the vulnerabilities, certain contributed modules must be enabled.
Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Entity Reference Tree Widget - Moderately critical - Cross Site Scripting - SA-CONTRIB-2022-026

Biztonsági figyelmeztetések (contrib) - 2022. február 23. 18.10
Project: Entity Reference Tree WidgetDate: 2022-February-23Security risk: Moderately critical 12∕25 AC:Complex/A:Admin/CI:Some/II:Some/E:Theoretical/TD:AllVulnerability: Cross Site ScriptingDescription: 

This module provides an entity relationship hierarchy tree widget for an entity reference field.

The module doesn't sufficiently filter on output, leading to a Cross Site Scripting vulnerability.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission to modify an entity that is the reference to a field.

Solution: 

Install the latest version:

Reported By: Fixed By: Coordinated By: 

Quick Edit - Moderately critical - Information Disclosure - SA-CONTRIB-2022-025

Biztonsági figyelmeztetések (contrib) - 2022. február 16. 18.07
Project: Quick EditDate: 2022-February-16Security risk: Moderately critical 12∕25 AC:None/A:User/CI:Some/II:None/E:Theoretical/TD:DefaultVulnerability: Information DisclosureDescription: 

This advisory addresses a similar issue to Drupal core - Moderately critical - Information disclosure - SA-CORE-2022-004.

The Quick Edit module does not properly check entity access in some circumstances. This could result in users with the "access in-place editing" permission viewing some content they are are not authorized to access.

Solution: 

Install the latest version:

Reported By: Fixed By: 

Drupal core - Moderately critical - Information disclosure - SA-CORE-2022-004

Biztonsági figyelmeztetések (core) - 2022. február 16. 17.46
Project: Drupal coreDate: 2022-February-16Security risk: Moderately critical 12∕25 AC:None/A:User/CI:Some/II:None/E:Theoretical/TD:DefaultVulnerability: Information disclosureDescription: 

The Quick Edit module does not properly check entity access in some circumstances. This could result in users with the "access in-place editing" permission viewing some content they are are not authorized to access.

Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.

Also see Quick Edit - Moderately critical - Access bypass - SA-CONTRIB-2022-025 which addresses the same vulnerability for the contributed module.

This advisory is not covered by Drupal Steward.

Solution: 

Install the latest version:

All versions of Drupal 9 prior to 9.2.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.

Drupal 7 core does not include the QuickEdit module and therefore is not affected.

Uninstalling the QuickEdit module will also mitigate the vulnerability. Site owners may wish to consider this option as the QuickEdit module will be removed from core in Drupal 10.

Reported By: Fixed By: