Biztonsági figyelmeztetések (core)
In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation.
This vulnerability only affects sites with the JSON:API module enabled, and can be mitigated by uninstalling JSON:API.
The core REST and contributed GraphQL modules are not affected.
Drupal Steward partners have been made aware of this issue. Some platforms may provide mitigations. However, not all WAF configurations can mitigate the issue, so it is still recommended to update promptly to this security release if your site uses JSON:API.Solution:
Install the latest version:
- If you are using Drupal 10.1, update to Drupal 10.1.4.
- If you are using Drupal 10.0, update to Drupal 10.0.11.
- If you are using Drupal 9.5, update to Drupal 9.5.11.
All versions of Drupal 9 prior to 9.5 are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.
Drupal 7 is not affected.Reported By: