Facebook hibás képet posztol - keresek valaklt, aki megoldja

charlos képe

Sziasztok!

Adott egy weboldal, ami OpenDeals disztribúció (Drupal 7 + Commerce + pár spéci modul)

Van egy olyan gondom, hogy amikor a Commerceben felveszek egy új terméket (Bolt->Termék->Termék hozzáadása), s itt töltöm fel a képet (field_image), majd a metatag modulban az Opengraph részen beírom, hogy: [node:field-image:file], egyszerűen nem tölti be a < meta type="og:image" .. sort.
Érthető, hiszen ahol feltöltöm a képet, az nem node.

Ha bárki megteszi, hogy megoldja a problémát, annak hajlandó vagyok fizetni is,

Melyik modulhoz, modulokhoz kapcsolódik a téma?: 
Drupal verzió: 
Illyés Edith képe

Gondolom arról van szó, hogy a product display node nem tölti be, mert nem magát a product-ot akarod megosztani Facebookon. :)

Valami olyasmi lesz a megoldás, hogy [node:field-commerce-product:field-image:file]. Az /admin/help/token oldalon ki van írva az összes token, onnan kell kihalászni a helyes formulát.

1
0
charlos képe

beillesztettem, de a meta property="og:image" content="ez/itt/a/commerce_product_kep.jpg" továbbra sincs, így értelemszerűen a Facebook továbbra is rossz képet posztol. :(

Mi lehet még a probléma?

Tényleg, ha valaki ránéz, nem leszek hálátlan!

0
0

--

Üdv:
Charlos

Illyés Edith képe

Ha nem oldódott meg, küldj egy üzenetet a hozzáférésekkel, de nem tudom, mikor lesz időm hosszasabban megnézni, lehet, hogy csak több nap múlva.

1
0
charlos képe

A [node:field-product:field_deal_image] token szükségleltetik a probléma megoldásához.

Egyébként ez egy bug is, amit a https://drupal.org/node/1305402#comment-6420040 címen található modul orvosol.

Köszönöm Illyés Edithnek a segítséget!

0
0

--

Üdv:
Charlos