Verziófrissítés Composerrel

nakos képe

Szeretném a drupal core-t 8.8.0 verzióra frissíteni a "composer update drupal/core webflo/drupal-core-require-dev symfony/* --with-dependencies" parancs segítségével.
Az alábbi hibaüzeneteket kaptam:
- Package "drupal/core" listed for update is not installed. Ignoring.
- Package "webflo/drupal-core-require-dev" listed for update is not installed. Ignoring.
- Dependency "paragonie/random_compat" is also a root requirement, but is not explicitly whitelisted. Ignoring.
-- nincs mit telepíteni vagy frissíteni.

Próbálkoztam a "composer outdated drupal/*" majd a "composer update drupal/core --with-dependencies" paranccsal. Ez is "nincs mit telepíteni vagy frissíteni." visszajelzéssel zárult.

Ti hogyan csináljátok a frissítést?

Melyik modulhoz, modulokhoz kapcsolódik a téma?: 
Drupal verzió: 
CsatolmányMéret
Kép ikon drupal_core_8.png29.85 KB
bcsaba képe

nevergone képe

Szia!

Gondolom van composer.json fájlod, megmutatnád a tartalmát?

0
0
nakos képe

  1. {
  2. "name": "drupal/drupal",
  3. "description": "Drupal is an open source content management platform powering millions of websites and applications.",
  4. "type": "project",
  5. "license": "GPL-2.0-or-later",
  6. "require": {
  7. "composer/installers": "^1.0.24",
  8. "wikimedia/composer-merge-plugin": "^1.4"
  9. },
  10. "replace": {
  11. "drupal/core": "^8.7"
  12. },
  13. "minimum-stability": "dev",
  14. "prefer-stable": true,
  15. "config": {
  16. "preferred-install": "dist",
  17. "autoloader-suffix": "Drupal8"
  18. },
  19. "extra": {
  20. "_readme": [
  21. "By default Drupal loads the autoloader from ./vendor/autoload.php.",
  22. "To change the autoloader you can edit ./autoload.php.",
  23. "This file specifies the packages.drupal.org repository.",
  24. "You can read more about this composer repository at:",
  25. "https://www.drupal.org/node/2718229"
  26. ],
  27. "merge-plugin": {
  28. "include": [
  29. "core/composer.json"
  30. ],
  31. "recurse": true,
  32. "replace": false,
  33. "merge-extra": false
  34. },
  35. "installer-paths": {
  36. "core": ["type:drupal-core"],
  37. "modules/contrib/{$name}": ["type:drupal-module"],
  38. "profiles/contrib/{$name}": ["type:drupal-profile"],
  39. "themes/contrib/{$name}": ["type:drupal-theme"],
  40. "drush/contrib/{$name}": ["type:drupal-drush"],
  41. "modules/custom/{$name}": ["type:drupal-custom-module"],
  42. "themes/custom/{$name}": ["type:drupal-custom-theme"]
  43. }
  44. },
  45. "autoload": {
  46. "psr-4": {
  47. "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
  48. }
  49. },
  50. "scripts": {
  51. "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
  52. "post-autoload-dump": "Drupal\\Core\\Composer\\Composer::ensureHtaccess",
  53. "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
  54. "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
  55. "drupal-phpunit-upgrade-check": "Drupal\\Core\\Composer\\Composer::upgradePHPUnit",
  56. "drupal-phpunit-upgrade": "@composer update phpunit/phpunit phpspec/prophecy symfony/yaml --with-dependencies --no-progress",
  57. "phpcs": "phpcs --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --",
  58. "phpcbf": "phpcbf --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --"
  59. },
  60. "repositories": [
  61. {
  62. "type": "composer",
  63. "url": "https://packages.drupal.org/8"
  64. }
  65. ]
  66. }

A szolgáltató a tarhely.eu

0
0
segi képe

8.8-as zip-et vagy tar.gz-t és cseréld ki a benne lévő composer.json a tiéddel majd futtass egy composer update-t. Jelenleg a drupal/core csomag maximum a 8.7 vagy valamelyik al-verzióját engedi. De nem elég a ^8.7-t ^8.8-ra cserélni mert, mert egy csomó másik csomag elérése is változott.
Ha az oldal használja a pathauto modul-t akkor előszőr azt frissítsd először azt 8.x-1.6.
Mielőtt elkezded a frissítést nem felejtsd el lementeni a fájlokat és az adatbázist, majd a végén hívd meg az update.php-t is.

0
0

Drupal developer at Cheppers